Usual tabs not opening when you launch Google Chrome browser? Check this

I always try to post about sorting out anything unusual happening on my PC in the hope that it may help someone else with the same problem.

I had a strange thing happen with Google Chrome browser this morning. I have Chrome set to open five tabs when it launches but none would open and I just got one tab of a blank page. When I opened Options (under the spanner icon), in the Basics menu, under On Startup , everything seemed fine. Open the following pages was checked and the correct 5 URLs were listed there to open on start up. So I closed Chrome, reopened it and the same thing happened. Chrome seemed to be ignoring the instruction to open 5 tabs and for some reason was just opening a blank home page.

So I played around with a few things and got nowhere until I opened task manager (Ctrl-Shift-Esc) and saw that even when Chrome was closed, a bunch of Chrome processes were still running under the Processes tab! It seemed that, although I’d closed Chrome, it was still running.

So I opened Chrome again and went to the Options menu as before to see if a preference setting was causing this. Sure enough, when I looked at the Under the Hood menu, the option at the bottom of that page called Background Apps was checked allowing background apps to keep running when Google Chrome was closed. Once I unchecked this and restarted Chrome, everything was back to normal and my usual 5 tabs opened without a hitch.

Chrome background apps

So how did that box get checked? Well, it wasn’t me. However I had run CCEnhancer/CCleaner just before opening Chrome and this may have somehow reset the preferences. Anyway I know what to do if it happens again. Hope this helps in troubleshooting this Chrome problem.

11 Responses

  1. Stephen Jen Says:

    Thanks for this post. I think for me it was because I installed offline apps for Gmail and Google Calendar, which may require some background processes to run.

  2. Jill Says:

    Thanks, this solved the problem for me. I installed a new Chrome app yesterday, which must have changed the setting.

  3. Heather Says:

    Thanks so much! – I had no idea why my usual (many) tabs were not opening despite them all still being listed – thanks to you it was very easily fixed.

  4. Matt88 Says:

    Thanks – This has been bugging me for a week. Just changed the setting, hope that it fixes it (have to check after a reboot)

  5. Matt88 Says:

    Didn’t work – back to google

  6. techandlife Says:

    Matt, Let us know if you find a solution.

  7. Tom Says:

    Awesome dude, this really helped!

  8. Emilie Says:

    Thanks! Solved my problem, and for me too it was after running CCleaner.

  9. Ryan Says:

    Awesome! I’m not running CCleaner, but this still did the trick for me. Thanks!

  10. Chase Says:

    My Chrome browser does not have Options, Under the Hood or Basic. I have Settings and More Tools but no where a Background Apps. I have a Set Pages and that all looks like the 5 pages I set to open. But it only opens my first tab on rebooting. I have a Chromebook, is this the differences?

  11. Laura Says:

    Thank you so much! This fixed my problem!

Leave a Comment

Please note: Comment moderation is enabled and may delay your comment. There is no need to resubmit your comment. Please do not use keywords in the Name field. Comments must relate to the post topic. This website is here to help people, not for advertising purposes.

Please complete puzzle and then submit your comment *
Time limit is exhausted. Please reload CAPTCHA.

` `